EIGRP Protocol

Enhanced Interior Gateway Routing Protocol (EIGRP) is an advanced distance vector routing protocol developed by Cisco that uses DUAL (Diffusing Update Algorithm) to find best paths quickly and without loops. This comprehensive guide covers all aspects of EIGRP configuration, operation, and troubleshooting for CCNP ENARSI preparation.

Table of Contents

EIGRP Overview and Features

Enhanced Interior Gateway Routing Protocol (EIGRP) is a Cisco proprietary routing protocol that blends features of distance vector and link-state protocols, often called a "hybrid protocol." It's engineered for fast convergence, efficient bandwidth use, and support for multiple network protocols like IPv4 and IPv6.

Key Features:

EIGRP excels in enterprise networks due to its scalability and adaptability.

EIGRP Packet Types

EIGRP uses five packet types:

  1. Hello: Discovers neighbors, sent every 5 seconds on LANs.
  2. Update: Shares routing info on topology changes.
  3. Query: Seeks alternate paths when a route fails.
  4. Reply: Responds to Queries with route details.
  5. ACK: Confirms receipt of Updates, Queries, or Replies.

Example: A router multicasts Hellos to 224.0.0.10, then sends Updates to new neighbors.

EIGRP Metrics and K-values

EIGRP's metric combines bandwidth, delay, reliability, and load, weighted by K-values (K1–K5). Defaults are K1=1 (bandwidth), K3=1 (delay), K2, K4, K5=0.

Adjust K-values:

router eigrp 100
 metric weights 0 1 0 1 0 0

To include reliability:

metric weights 0 1 0 1 1 0

K-values must match for adjacency.

EIGRP Metric Calculation

Default formula: Metric = [(10^7 / min_bandwidth) + (sum_delay / 10)] × 256

Example 1: 10 Mbps, 10 ms delay:

Example 2: T1 (1544 kbps), 20 ms delay:

EIGRP Configuration

Basic (IPv4):

router eigrp 100
 network 192.168.1.0 0.0.0.255
 network 10.0.0.0 0.255.255.255

Advanced: Adjust timers:

interface GigabitEthernet0/0
 ip hello-interval eigrp 100 5
 ip hold-time eigrp 100 15

EIGRP for IPv4 and IPv6

Named mode supports both:

router eigrp MY_EIGRP
 address-family ipv4 unicast autonomous-system 100
  network 192.168.1.0 0.0.0.255
 exit-address-family
 address-family ipv6 unicast autonomous-system 100
  network 2001:db8::/64
 exit-address-family

EIGRP Neighbor Relationships

Neighbors form when AS, K-values, and authentication align. Check with:

show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address       Interface  Hold Uptime   SRTT RTO  Q  Seq
0   192.168.1.2   Gi0/0      14   00:05:23 10   200  0  5

DUAL Algorithm

DUAL picks the successor (best path) and feasible successors (backups). A feasible successor's RD < FD.

Example: FD=1000, Neighbor B RD=800 (feasible), Neighbor C RD=1200 (not feasible).

Feasibility Condition

RD < FD ensures loop-free backups. RD is the neighbor's metric; FD is the best metric.

Example: FD=1000, RD=800 (feasible), RD=1100 (not feasible).

EIGRP Topology Table

Stores all routes:

show ip eigrp topology
P 192.168.2.0/24, 1 successors, FD is 30720
 via 192.168.1.2 (30720/28160), Gi0/1
 via 192.168.1.3 (40960/28160), Gi0/2

EIGRP Stub Routing

Limits queries:

router eigrp 100
 eigrp stub connected summary

EIGRP Route Summarization

Manual summarization:

router eigrp 100
 no auto-summary
interface Gi0/0
 ip summary-address eigrp 100 10.0.0.0 255.0.0.0

EIGRP Authentication

MD5:

key chain EIGRP_KEY
 key 1
  key-string mysecret
interface Gi0/0
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 EIGRP_KEY

Passive Interfaces

router eigrp 100
 passive-interface Gi0/1

Stops hellos on Gi0/1.

Load Balancing

Unequal-cost with variance:

router eigrp 100
 variance 2

EIGRP Timers

Default: Hello=5s, Hold=15s. Adjust:

interface Gi0/0
 ip hello-interval eigrp 100 10
 ip hold-time eigrp 100 30

Route Filtering

Prefix-list example:

ip prefix-list ALLOW permit 10.0.0.0/8
router eigrp 100
 distribute-list prefix ALLOW in

EIGRP Over Frame Relay/NBMA

router eigrp 100
 neighbor 192.168.1.2 Serial0/0
interface Serial0/0
 bandwidth 1544

Troubleshooting EIGRP

Commands:

EIGRP Named Mode

router eigrp MY_EIGRP
 address-family ipv4 unicast autonomous-system 100
  network 192.168.1.0 0.0.0.255
  af-interface Gi0/0
   hello-interval 10
  exit-af-interface
 exit-address-family